Search:

OpenNab

languages

Téléchargement et installation

Téléchargement

La version 0.09 est disponible sur SourceForge : https://sourceforge.net/projects/opennab/files/opennab/opennab_0.09/opennab_0.09.zip/download

Pour être tenu au courant des nouvelles versions publiées, vous pouvez souscrire au flux RSS des packages OpenNab

Pré-requis

  • Un Nabaztag/tag (OpenNab ne fonctionne pas avec la 1ère version du Nabaztag, celle sans nombril)
  • Un serveur Apache (utilisation de la directive ErrorDocument des fichiers .htaccess) avec PHP (4.4.x or 5.2.x)

Installation

  1. Mettre tous les fichiers dans un dossier du serveur web.
    • Ce dossier doit être la racine d'un domaine ou d'un sous-domaine (exemple : mon.domaine.fr)
  2. Assurez-vous que les dossiers ne sont pas protégés en écriture.
    • OpenNab a besoin d'écrire dans les dossiers : /vl/burrows, /vl/logs, /vl/plugins/*/files
    • Si vous utilisez un client FTP tel que FileZilla pour installer OpenNab, vous pouvez faire un click droit sur un fichier distant et choisir 'Attributs du fichier...' pour changer les droits d'accès.
  3. Avec un navigateur web quelconque, allez sur http://mon.domaine.fr/vl/foobar
    • L'erreur suivante devrait être affichée : 'ERROR 404 from OpenNab'. Quelques navigateurs (par exemple, Internet Explorer) peuvent avoir besoin d'une option de configuration pour afficher ce message
    • Si elle ne s'affiche pas, vous avez un problème avec la configuration d'Apache (la directive ErrorDocument dans .htaccess n'est peut être pas disponible).
    • Vous devez régler cela avant d'aller plus loin.
  4. Avec un navigateur web quelconque, allez sur http://mon.domaine.fr/vl/tests/
    • Vous devriez voir une bande verte avec tous les tests réussis.
    • Dans le cas contraire, il y a un problème avec Apache ou PHP. OpenNab ne fonctionne pas dans votre configuration.
    • Si vous avez une telle erreur avec PHP 4.4.x ou 5.2.x, demandez de l'aide sur le forum : http://sourceforge.net/forum/forum.php?forum_id=654766
    • Si vous avez une telle erreur avec une autre version de PHP, c'est normal. Vous devez mettre à jour votre version de PHP.
  5. Avec un navigateur web quelconque, allez sur http://mon.domaine.fr/vl/bc.jsp?v=0.0.0.10&m=xx:xx:xx:xx:xx:xx&l=00:00:00:00:00:00&p=00:00:00:00:00:00&h=4
    • Vous devriez voir une page de texte bizarre débutant par le mot 'amber'.
    • Si vous n'avez rien ou une erreur, vérifiez votre configuration et, le cas échéant, demandez de l'aide.
  6. Si tous les étapes précédentes passent correctement, vous pouvez mettre à jour la configuration de votre lapin
Edit - Print